Intermittent issue with external banking system EPX

Incident Report for Segpay

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 17:59 UTC

Update

Services are restored.
Posted Aug 13, 2026 - 17:57 UTC

Investigating

Segpay has identified an intermittent issue with external banking system EPX that is impacting a small number of transactions. Backend processes including rebills have been paused as a precaution until the issue is confirmed to be resolved.
Posted Aug 13, 2026 - 17:20 UTC
This incident affected: Segpay Rebiller.