Main marketing website issue
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Dec 04, 2023 - 13:36 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 01, 2023 - 17:29 UTC
Identified
The issue has been identified to be caused by hosting provider, outside of segpay systems. Our ITOPs team is actively in communication with them to get an eta on resolution
Posted Dec 01, 2023 - 17:28 UTC
Investigating
We are looking into an issue with limited access to www.segpay.com
Posted Dec 01, 2023 - 17:25 UTC
This incident affected: Marketing site - Segpay.com.