Intermittent issue affecting pay pages
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 03:35 UTC
Monitoring
This issue has been resolved and Segpay will continue to monitor.
Posted Mar 24, 2023 - 00:37 UTC
Investigating
Segpay has identified an intermittent issue affecting pay pages and we are working on a solution.
Posted Mar 23, 2023 - 23:59 UTC
This incident affected: Paypages and PayPal.