Investigating issues with Merchant Portal consumer search features
Incident Report for Segpay
Resolved
This issue has been resolved.
Posted Apr 13, 2022 - 17:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 13, 2022 - 16:00 UTC
Investigating
Segpay is currently investigating issues with the Merchant Portal consumer search features.
Posted Apr 13, 2022 - 15:44 UTC
This incident affected: Merchant Portal.