Issue with the Segpay Merchant Portal
Incident Report for Segpay
Resolved
Incident resolved.
Posted Feb 13, 2023 - 01:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2023 - 00:35 UTC
Investigating
Segpay is currently experiencing an issue with the Merchant Portal. We are actively working on a solution.
Posted Feb 12, 2023 - 23:45 UTC
This incident affected: Merchant Portal.