Intermittent issue with external banking system Kalixa

Incident Report for Segpay

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 13:36 UTC

Monitoring

We are currently monitoring an issue with a downstream vendor that may be causing intermittent declines.
Posted Aug 15, 2026 - 05:02 UTC