Connectivity Issue (Vendor Related)
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:21 UTC
Investigating
We are currently investigating an issue with connectivity outside of the Segpay Network. Some customers may experience issues.
Posted Jun 21, 2022 - 07:06 UTC
This incident affected: Segpay Network Connectivity.