Intermittent issue affecting pay pages

Incident Report for Segpay

Resolved

The issue has been resolved and paypages are back online.
Posted Apr 17, 2025 - 18:55 UTC

Identified

The issue has been identified and engineers are working on the issue.
Posted Apr 17, 2025 - 18:31 UTC

Investigating

Segpay is currently investigating an intermittent issue affecting paypages.
Posted Apr 17, 2025 - 17:18 UTC
This incident affected: Paypages and PayPal.