Paypal Transactions Issue
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 22:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2023 - 20:29 UTC
Investigating
We are currently investigating an issue with processing paypal transactions..
Posted Jun 22, 2023 - 19:10 UTC
This incident affected: PayPal.