Merchant Portal Delays
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 13:28 UTC
Monitoring
No immediate impact reported by consumers. We continue to monitor this.. If you are experiencing degraded performance, please contact the Support team at help@segpay.com
Posted Jun 09, 2020 - 17:16 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2020 - 17:15 UTC
Identified
This minor issue has been identified, and we are working towards a fix. At the moment there are no global impacts to consumers. If you are experiencing issues, please contact us.
Posted May 29, 2020 - 12:12 UTC
Update
We've identified no immediate impact to consumers. However, continue to monitor the systems.
Posted May 20, 2020 - 22:17 UTC
Update
We are continuing to investigate this issue.
Posted May 20, 2020 - 14:30 UTC
Investigating
We are currently investigating delays in loading the Merchant Portal page. We appreciate your patience while our development team addresses the concern.
Posted May 19, 2020 - 22:13 UTC
This incident affected: Merchant Portal.