Segpay Email Service disruption
Incident Report for Segpay
Resolved
The incident has been resolved
Posted Jan 21, 2021 - 13:39 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 20, 2021 - 21:57 UTC
Monitoring
A fix has been implemented and are currently monitoring.
Posted Jan 20, 2021 - 21:43 UTC
Identified
Our email service provider is having issues. This may impact consumer communication(s) such as receipts and cancellation notices. We are currently working with the provider
Posted Jan 20, 2021 - 20:50 UTC
This incident affected: Segpay Consumer Email Service.