Merchant Portal Financial Reporting
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 19:05 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 21, 2021 - 17:57 UTC
Monitoring
We have addressed the issue with our financial reporting system within our Merchant Portal. We will continue to monitor it and update accordingly. If you experience any issues, please contact techsupport@segpay.com
Posted Jan 21, 2021 - 17:56 UTC
Identified
We've identified a fix, currently being tested
Posted Jan 21, 2021 - 13:17 UTC
Update
We are continuing to investigate this issue.
Posted Jan 20, 2021 - 20:43 UTC
Investigating
We have currently identified an issue with our financial reporting system within our Merchant Portal. The reporting system will be down until further notice. If you need any financial reports, please contact techsupport@segpay.com
Posted Jan 20, 2021 - 20:42 UTC
This incident affected: Merchant Portal.