SRS Delays
Incident Report for Segpay
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 13:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2020 - 17:15 UTC
Update
We are continuing to investigate this issue. If you are experiencing degraded performance, please contact the Support team.
Posted Jun 04, 2020 - 13:54 UTC
Identified
Our team has identified delays in some SRS reports. We are currently investigating.
Posted Jun 03, 2020 - 19:25 UTC
This incident affected: SegPay Merchant B2B Web Services (SRS).